Feedback to Kingsoft Office/WPS Office for Linux.
10 posts Page 1 of 1
Hi
I have installed the Latest version of WPS [2014] in Ubuntu 14.04 and liking it . One issue i noticed and not able to fix is with Fonts.

Although i have installed the MS trutype fonts [.ttf] on Ubuntu , in writer or other WPS applications, While I notice the Arial / Times New roman available in the font drop-down, as soon as i select it automatically [and immediately] changes to either Droid Sans / Noto Serif .

Can you please help me to fix this issue and enable to use the installed MS fonts?

Thanks in Advance.


Suraj Prabhu
Hi, how did you installed the MS fonts? I place them to ~/.fonts, and it works for me.
Is the Arial/Times New Roman works for other applications?
I have the same problem, using elementary OS Freya, which is based on that version of Ubuntu. I have reinstalled the fonts many times and did likewise with the program itself with to no avail. Even the update to the latest alpha did not fix it. The fonts work well in LibreOffice, which is what I will be using until this problem is fixed. If there is any way to fix it, please let me know. I personally prefer to use WPS, but this issue with the fonts is preventing me. I am one of very few linux users at my school, and I need to be able to use the MS core fonts for the sake of getting full credit for assignments.
natepul wrote: I have the same problem, using elementary OS Freya, which is based on that version of Ubuntu. I have reinstalled the fonts many times and did likewise with the program itself with to no avail. Even the update to the latest alpha did not fix it. The fonts work well in LibreOffice, which is what I will be using until this problem is fixed. If there is any way to fix it, please let me know. I personally prefer to use WPS, but this issue with the fonts is preventing me. I am one of very few linux users at my school, and I need to be able to use the MS core fonts for the sake of getting full credit for assignments.

I copied the Windows fonts into "/home/duke/.fonts", after restart it works perfectly.
Could you please provide us more information and make sure you have put the fonts into .fonts folder in current user's directory?
Hi, I'm a new user of WPS Office. I have this same problem. I installed all the MS Fonts but WPS won't recognize some of them: Times New Roman and Verdana. This fonts are indeed in the /.fonts directory. I don't know why WPS won't "see" them. I use Linux Mint 17.1 Xfce.
This bug is annoying because Times New Roman is widely used in MS Office documents.
I have a similar problem. My WPS Office won't recognize some windows fonts: times new roman and verdana. And these fonts are indeed in the /.fonts directory and recognized by the system. I don't know why WPS Office can't "see" them. My distro is Linux Mint 17.1 Xfce.
I need to use Times New Roman, and it automatically changes to Tinos whenever I click on Times New Roman. I have put the fonts into the .fonts directory with no change. I'm running it on Elementary OS Freya, which is based on Ubuntu 14.04. Even when trying to open a file that uses Times New Roman, it changes to Tinos. Is there a way I can to a clean reinstall of WPS without any settings remaining? Whenever I remove it and reinstall, it loads all the preferences I had before. Perhaps there is some rogue setting that I inadvertently clicked on when setting up WPS that is keeping Writer from recognizing the font (I'm kind of new to Linux, but I'm learning slowly but surely).

Edit: after checking, I have found that Times New Roman works in Spreadsheet, but not in Writer or Presentation. So if I could get it to work in Writer, I would be good to go
I have installed latest wps-office in fedora22. I have copied fonts in home directory. HINDI fonts correctly displayed in libreoffice. It does not display correctly in wps-office.

It worked correctly in fedora21. I do not know whether it is due to fedora or wps that it now does not work.
I'm registering to this forum just to say that I'm having the same problem. Times New Roman is installed (ttf-mscore), but can't be used by WPS - except in Spreadsheet. My distro is elementary OS Freya x64, WPS installed is version A18P1 x64.
Same issue on mint 17.2. I try put in ~/.fonts, but with no result. :(
10 posts Page 1 of 1

Who is online

Users browsing this forum: No registered users and 4 guests