Translate KSO/WPS, Discussions on community building, and more...
241 posts Page 2 of 25
Previous 1, 2, 3, 4, 5 ... 25 Next
I downloaded the extra fonts from the FAQ posting. I was a zip folder with about seven font sets. When I tried to extract the fonts I was told I don't have permission to write to the Share/fonts/WPS fonts folder. I probably need sudo or administrator privileges, which I have on this machine.

I figured out how to install the extra fonts and symbol fonts. Specifically, open a command line terminal and type in

sudo nautilus
That will open Nautilus. Open the share/fonts/Wps-fonts folder and then open another tab in nautilus. Paste in the fonts extracted from the zip folder listed in FAQ. Then you can copy and paste into the initial share/fonts/wps-fonts folder inside nautilus and since you are a sudo your paste will work. The extra fonts are installed, hooray.

all the best
hi to all of you. I have a serious problem about launching WPS office. I downloaded the 32 package from this site and installed it on my ubuntu 14.04 32 bit. All seemed to be well. icones moved to the wps form. But when i want to launch the soft, nothing happen. when i type wps or kingsoft in the terminal, i receive this message: wps does not exist! or kingsoft : commande introuvable

please a help.
Hi Alberto:
I'll tell you what I did that worked for me. Your milage may vary.

I downloaded the 32 bit .deb file from the site here I think. I then tried to install it with the package GDebi, which installs debian program files in Ubuntu. At that point I got a pop up telling me I needed to install the package that allows 32 bit programs to run on 64 bit Linux (I don't remember what it was). I said yes, it downloaded and installed it all by itself (now that is good software!) and then proceeded to install Kingsoft Office. It ran right out of the box. I hope it works for you. I am running Ubuntu 12.04, so I don't know how well 14.04 works with 32 bit software.

all the best
I am not a linux person, but I use it and like is as a desktop user. I tried to install it on my 64-bit Ubunto but I was not really sure what commands to use (to paste into terminal). I think it would be simpler for us linux novices if you put ALL the commands for 32-bit in one "list" and all the commands for 64-bit in another "list".

So far I ran what I thought were the appropriate commands in terminal and I do not think it installed. Perhaps you could drop me a note at

The Ubuntu "software center" applicaton does not seem to have WPS as an installation candidate. The software center always seems to work...
jojothehobo wrote: Sergey, thanks for your reply. Did you install the 32 bit version or a 64 bit version. I have a 64 bit processor (AMD 64) and would prefer that, but if the 32 bit is the only one that works I can deal with that too.

There is no 64-bit release available yet (only some unstable packages to test), but it is a great effort and software for Linux. See this thread for details -
There is still a lot to do for this package to run without errors.
This is a really nice piece of software - don't want to give the team more work but since you have a deb already it would be nice to add it in the software center so that nontechnical people can install it with ease.
They already have a .deb in the Ubuntu software center, but it is an older version (2 generations ago). Still, that version is the fastest loading version of any office suite I've ever had. The latest version is improved and loads pretty fast. The spreadsheet program is still loads a bit slowly (20-30 seconds) but all of them work well and have near perfect compatibility with MS Office.

Jojo :)
Hi All:
I just installed the latest WPS Office in Ubuntu 12.04 (alpha 16 patch 2). Writer and Presentation are great and improved and start up really quickly. Spreadsheets takes around 45 seconds to start up after an initial quick start splash sheet saying WPS Office. I don't know if the slowness is due to my using Ubuntu 12.04 or is a result of WPS Spreadsheet. I'd be interested in hearing of the experiences of others.

WPS is the most MS Office compatible of all the Linux Office suites and would probably dominate the market if they could get the Spreadsheet boot time under 15 seconds. I still use it because I like the compatibility, but I still use gnumeric or Libre Office spread sheets for those functions. The functionality of Libre Office and gnumeric are ahead of WPS, especially with the plug ins, but the speed and slickness of WPS makes it my favorite. Sometimes I can wait for spreadsheet to open when I am multi tasking, or starting a new project, but when I am opening a file I find it annoying to have to wait that long.

all the best
I am using Linux Mint 17, based on Ubuntu 14.04 and my spreadsheet start time is under 10 seconds.

Big compliments to the WPS developer team btw, the only office suite that allows me to use Linux in a Microsoft dominated company. Keep up the excellent work please.
Thanks William, for clarifying your experience. It seems reasonable that one has to make some sacrifices for using an older OS. I've thought of upgrading from 12.04 to 14.04, but I have a bunch of applications installed and my system is working well.

I've heard that upgrading in place can cause some configuration problems with the existing software versions (forward compatibility), so I plan to stay with the 12.04 until 16.04 comes out. I hope Canonical, under new leadership, doesn't abandon their LTS schedule.

all the best

Jojo 8-)
Previous 1, 2, 3, 4, 5 ... 25 Next
241 posts Page 2 of 25

Who is online

Users browsing this forum: No registered users and 1 guest