Translate KSO/WPS, Discussions on community building, and more...
93 posts Page 7 of 10
Previous 1 ... 4, 5, 6, 7, 8, 9, 10 Next
No. Still the same.
See screenshots attached how it must be (in OpenOffice) and wrong output in Writer -

Attachments

Sergey Chepurin wrote: No. Still the same.
See screenshots attached how it must be (in OpenOffice) and wrong output in Writer -

I have test it and everything is ok. (a15 on ubuntu).
Have you installed libpango1 library?
ken i wrote: I have test it and everything is ok. (a15 on ubuntu).
Have you installed libpango1 library?

Now this... You never mentioned i would have to install this library for Hebrew (always told about Arabic language's support). Anyway, seems i should trust you on this(?), as i don't want to mess with another package of unknown libraries with no positive warranty and don't need Hebrew language's support (just want to check that it was possible on Linux).
Small advice - if you want for people do not bother you often with questions about RTL language support, then write some short note on what and how it to be installed.
I agree with Sergey. The dependencies should come or already discriminated against in the deb control file or at least listed in the download area. The inclusion of dependencies is part of good policy development and avoids many unnecessary questions that consume time that could be used to develop other tools.
Sergey Chepurin wrote:
ken i wrote: I have test it and everything is ok. (a15 on ubuntu).
Have you installed libpango1 library?

Now this... You never mentioned i would have to install this library for Hebrew (always told about Arabic language's support). Anyway, seems i should trust you on this(?), as i don't want to mess with another package of unknown libraries with no positive warranty and don't need Hebrew language's support (just want to check that it was possible on Linux).
Small advice - if you want for people do not bother you often with questions about RTL language support, then write some short note on what and how it to be installed.

Hi,
I am sorry, It is my fault.
If you want wps support complex languages(Arabic, Hebrew, Thailand, etc) on linux, have to install libpango1 library.
No. Sorry to disappoint you, but Hebrew doesn't work correctly even with libpango1 installed.
I cant use A15 for arabic language. :cry:
Image
hamed zara wrote: I cant use A15 for arabic language. :cry:
Image

Hi,
Are you sure you have installed libpango1.0-0 ? I couldn't see this library in your picture.

Thanks
Sergey Chepurin wrote: No. Sorry to disappoint you, but Hebrew doesn't work correctly even with libpango1 installed.

Hi,
Can you send me these information?
terminal output,
snapshot of wps,

whether you installed pango-1.0?

Thanks
ken i wrote: Can you send me these information?
terminal output,
snapshot of wps,
whether you installed pango-1.0?
Thanks

Now we need pango-1.0? No, it is not installed. But you mentioned only libpango1.0-0. And this library usually comes pre-installed with Ubuntu (sure it is with 12.04). We try to tell you that RTL languages are not printed right-to-left, they still output left-to-right.

Attachments

Previous 1 ... 4, 5, 6, 7, 8, 9, 10 Next
93 posts Page 7 of 10

Who is online

Users browsing this forum: No registered users and 1 guest