Official Announcements
328 posts Page 1 of 33
Previous 1, 2, 3, 4, 5 ... 33 Next
Installing WPS (Kingsoft) Office for Linux



Well if you deal with lots of MS document formats in your daily life it has very good compatibility with MS formats.
It looks and functions like MS Office.
It feels much lighter and faster than Libre Office on my old 2005 Celeron Laptop.
It's received some really good reviews online.

Cons: Proprietary license which some people might have an issue with.

Ok, on to the installation:

Code: Select all
sudo pacman -S libpng12

Create a tmp folder in home if you don't already have one else you are going to get an error about running out of space, I dunno why this happens.

Code: Select all
TMPDIR=/home/<username>/tmp yaourt -S wpsforlinux

Edit the pkgbuild, wpsoffice-common should be arch=('any') & wpsoffice should be arch=('i686' 'x86_64')

Ok when you start the app you are going to get an error about some missing fonts, there's a fix for this but I have to go find it.

Secondly when you open the app(s) it automatically opens a tab which is a web page from WPS, there's a way to disable this but once again I have to go find it.
Since you use pacman, I assume you are using Arch Linux,
there's an AUR for this app
It's quit easy for installation :D
I'm running LMDE (Debian SID) x64. Are there any plans to offer a 64 bit .deb package through the upstream repositories, or alternatively offered through a Kingsoft repository?

This is how Oracle distribute VirtualBox so it can be done.
coorrector package in some Spanish dictionary? would help me a lot, I have lubuntu 14.04, linux mint 17 xfce and lxde debian 7 thanks .
I tried to install wps-office_9.1.0.4751~a15_i386.deb in Ubuntu 14.04.1 and not able to install all dependencies. Any of the dependencies issues error to fix "apt-get -f install" and removes the other dependencies and goes on...
Is there any straight forward way to fix this.
Try to install wps through Gdebi (an alternative to the ubuntu software center / installer).
Once Gdebi has been installed, right click on the wps .deb file and open it with Gdebi.
The installation should run without any freezes or crashes.
So, what about installing the rpm under RHEL 6.5? When I run rpm -ivh on the main RPM, I receive the following error:

Code: Select all
12:09 agamemnon{root}> rpm -ivh wps-office-
error: Failed dependencies: is needed by wps-office-
12:10 agamemnon{root}>

But looking at the installed libstdc++ pkgs, I think I have my bases covered:

Code: Select all
12:10 agamemnon{root}> yum list installed |grep libstdc
compat-libstdc++-296.i686         2.96-144.el6       @anaconda-RedHatEnterpriseLinux-201206132210.x86_64/6.3
compat-libstdc++-33.i686          3.2.3-69.el6       @anaconda-RedHatEnterpriseLinux-201206132210.x86_64/6.3
compat-libstdc++-33.x86_64        3.2.3-69.el6       @anaconda-RedHatEnterpriseLinux-201206132210.x86_64/6.3
libstdc++.i686                    4.4.7-4.el6        @upgrade                   
libstdc++.x86_64                  4.4.7-4.el6        @upgrade                   
libstdc++-devel.i686              4.4.7-4.el6        @RHEL-65-x86_64           
libstdc++-devel.x86_64            4.4.7-4.el6        @upgrade                   
13:09 agamemnon{root}>

also, the release and kernel ifo from my system:

Code: Select all
13:09 agamemnon{root}> cat /etc/redhat-release 
Red Hat Enterprise Linux Workstation release 6.5 (Santiago)
13:09 agamemnon{root}> uname -a
Linux 2.6.32-431.30.1.el6.x86_64 #1 SMP Wed Jul 30 14:44:26 EDT 2014 x86_64 x86_64 x86_64 GNU/Linux
13:10 agamemnon{root}>

I've also run a find to make sure I have hte installed, and that there are 32-bit and 64-bit versions available:

Code: Select all
13:10 agamemnon{root}> find /usr -name "*" -exec ls -al {} ';'
-rw-r--r--. 2 root root 933 Jun 27 09:50 /usr/share/gdb/auto-load/usr/lib/
-rw-r--r--. 1 root root 2278 Jun 27 09:50 /usr/share/gdb/auto-load/usr/lib/
-rw-r--r--. 2 root root 933 Jun 27 09:50 /usr/share/gdb/auto-load/usr/lib/
-rw-r--r--. 2 root root 937 Jun 27 09:50 /usr/share/gdb/auto-load/usr/lib64/
-rw-r--r--. 1 root root 2280 Jun 27 09:50 /usr/share/gdb/auto-load/usr/lib64/
-rw-r--r--. 2 root root 937 Jun 27 09:50 /usr/share/gdb/auto-load/usr/lib64/
total 956
drwxr-xr-x.  2 root root   4096 Mar 11 14:12 .
drwxr-xr-x. 99 root root   4096 Mar 11 14:13 ..
-rw-r--r--.  1 root root 969528 Mar 11 14:12
-rw-r--r--. 1 root root 969528 Mar 11 14:12 /usr/lib/vmware/lib/
lrwxrwxrwx. 1 root root 19 Apr 18 09:07 /usr/lib/ ->
-rwxr-xr-x. 1 root root 942040 Jul 19  2013 /usr/lib/
lrwxrwxrwx. 1 root root 19 Apr 18 08:57 /usr/lib64/ ->
-rwxr-xr-x. 1 root root 989840 Jul 19  2013 /usr/lib64/
13:12 agamemnon{root}>

So, what have I missed? I feel like it has to be something simple.
Hello Guys ^^ .. First, I wanna say Thanks to WPS office developer who give me happiness because ... for the first time, I found alternative "Free & Reliable" office for microsoft office that "So Expensive" for me and my ubuntu 14.04 OS, I'm Very Gratefull for that And Next, I want to share a little problem that I have with the office the I hope for helping wps office development in the future.. oke.. here my problem... it seems i cant copy "text & picture" in the website to the wps writer together,,, the text is copied but the picture is not ... then i tried to just copying picture.. but it still can't.. i tried to paste special.. but also not displayed in the writer... i hope this can be fixed soon in the future, thanks before... I love U all "great wps developer" (and sorry for the language.. because I'm not very good in English ^^)


I am under linux mint 13 Maya. I really enjoyed WPS so far, especially the Writer, which has far better functionality than Libre Office. However, it cannot display graphs and pictures embedded in docx files either.

The problem right now, is that v. alpha 16 does not install properly. The menus does not show up, and if I try to open WPS files, I get the message there is no program installed to handle the file. I did uninstall v.15 before installing v. 16. I dont think I ever tried any of those MUI files, but I downloaded som fonts.

I reinstalled v. 15, and everything works.

I am aware of the script file, but do not want to fiddle around to get this to work. Hope the next update will have a working install package.

Keep up the good work. Would be great to improve the Spreadsheet, which is lagging a bit behind the presentation and the writer program.

Previous 1, 2, 3, 4, 5 ... 33 Next
328 posts Page 1 of 33

Who is online

Users browsing this forum: No registered users and 1 guest